bl2tools/bl2tools.spec
2022-05-05 17:31:31 -04:00

53 lines
970 B
Python

# -*- mode: python ; coding: utf-8 -*-
import izzylib_http_async
from pathlib import Path
block_cipher = None
a = Analysis(
['bl2tools.py'],
pathex=[],
binaries=[],
datas=[
(str(Path(izzylib_http_async.__file__).parent.joinpath('frontend')), '/izzylib_frontend'),
('bl2tools/frontend/*', '/frontend')
],
hiddenimports=[
'izzylib_http_async.server.application',
'http_router.utils'
],
hookspath=[],
hooksconfig={},
runtime_hooks=[],
excludes=[],
win_no_prefer_redirects=False,
win_private_assemblies=False,
cipher=block_cipher,
noarchive=False,
)
pyz = PYZ(a.pure, a.zipped_data, cipher=block_cipher)
exe = EXE(
pyz,
a.scripts,
a.binaries,
a.zipfiles,
a.datas,
[],
name='bl2tools',
debug=None,
bootloader_ignore_signals=False,
strip=False,
upx=True,
upx_exclude=[],
runtime_tmpdir=None,
console=True,
disable_windowed_traceback=False,
argv_emulation=False,
target_arch=None,
codesign_identity=None,
entitlements_file=None
)